CVE-2015-2151

NameCVE-2015-2151
DescriptionThe x86 emulator in Xen 3.2.x through 4.5.x does not properly ignore segment overrides for instructions with register operands, which allows local guest users to obtain sensitive information, cause a denial of service (memory corruption), or possibly execute arbitrary code via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3181-1
NVD severityhigh (attack range: local)
Debian Bugs780227

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)wheezy4.1.4-3+deb7u9fixed
wheezy (security)4.1.6.lts1-10fixed
jessie4.4.1-9+deb8u9fixed
jessie (security)4.4.1-9+deb8u10fixed
buster, stretch (security), stretch, sid4.8.1-1+deb9u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensource(unstable)4.4.1-8high780227
xensourcesqueeze(unfixed)end-of-life
xensourcewheezy4.1.4-3+deb7u5highDSA-3181-1

Notes

[squeeze] - xen <end-of-life> (Not supported in Squeeze LTS)
http://xenbits.xen.org/xsa/advisory-123.html

Search for package or bug name: Reporting problems