CVE-2015-2153

NameCVE-2015-2153
DescriptionThe rpki_rtr_pdu_print function in print-rpki-rtr.c in the TCP printer in tcpdump before 4.7.2 allows remote attackers to cause a denial of service (out-of-bounds read or write and crash) via a crafted header length in an RPKI-RTR Protocol Data Unit (PDU).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3193-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tcpdump (PTS)wheezy4.3.0-1+deb7u2fixed
wheezy (security)4.9.2-1~deb7u1fixed
jessie4.9.0-1~deb8u1fixed
jessie (security)4.9.2-1~deb8u1fixed
stretch (security), stretch4.9.2-1~deb9u1fixed
buster, sid4.9.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tcpdumpsource(unstable)4.6.2-4medium
tcpdumpsourcesqueeze(not affected)
tcpdumpsourcewheezy4.3.0-1+deb7u2mediumDSA-3193-1

Notes

[squeeze] - tcpdump <not-affected> (Vulnerable code not present)
http://www.ca.tcpdump.org/cve/0002-test-case-files-for-CVE-2015-2153-2154-2155.patch

Search for package or bug name: Reporting problems