CVE-2015-2156

NameCVE-2015-2156
DescriptionNetty before 3.9.8.Final, 3.10.x before 3.10.3.Final, 4.0.x before 4.0.28.Final, and 4.1.x before 4.1.0.Beta5 and Play Framework 2.x before 2.3.9 might allow remote attackers to bypass the httpOnly flag on cookies and obtain sensitive information by leveraging improper validation of cookie name and value characters.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs646523, 793770, 796114

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
netty (PTS)wheezy, jessie1:3.2.6.Final-2vulnerable
stretch1:4.1.7-2fixed
buster, sid1:4.1.7-4fixed
netty-3.9 (PTS)jessie3.9.0.Final-1vulnerable
buster, sid, stretch3.9.9.Final-1fixed
netty3.1 (PTS)wheezy3.1.0.CR1-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nettysource(unstable)1:4.0.31-1medium796114
netty-3.9source(unstable)3.9.9.Final-1medium793770
netty3.1source(unstable)(unfixed)medium
playframeworkITP646523

Notes

[wheezy] - netty3.1 <no-dsa> (Minor issue)
[jessie] - netty <no-dsa> (Minor issue)
[wheezy] - netty <no-dsa> (Minor issue)
[jessie] - netty-3.9 <no-dsa> (Minor issue)
[squeeze] - netty <no-dsa> (Minor issue)
http://netty.io/news/2015/05/08/3-9-8-Final-and-3.html
https://www.playframework.com/security/vulnerability/CVE-2015-2156-HttpOnlyBypass
http://web.archive.org/web/20150925094949/http://engineering.linkedin.com/security/look-netty%E2%80%99s-recent-security-update-cve%C2%AD-2015%C2%AD-2156
https://github.com/slandelle/netty/commit/800555417e77029dcf8a31d7de44f27b5a8f79b8

Search for package or bug name: Reporting problems