CVE-2015-2172

NameCVE-2015-2172
DescriptionDokuWiki before 2014-05-05d and before 2014-09-29c does not properly check permissions for the ACL plugins, which allows remote authenticated users to gain privileges and add or delete ACL rules via a request to the XMLRPC API.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs779547

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dokuwiki (PTS)jessie0.0.20140505.a+dfsg-4fixed
jessie (security)0.0.20140505.a+dfsg-4+deb8u1fixed
bullseye, sid, buster0.0.20180422.a-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dokuwikisource(unstable)0.0.20140929.d-1779547
dokuwikisourcejessie0.0.20140505.a+dfsg-4
dokuwikisourcesqueeze(not affected)
dokuwikisourcewheezy(not affected)

Notes

[squeeze] - dokuwiki <not-affected> (Vulnerable code not present)
[wheezy] - dokuwiki <not-affected> (Vulnerable code not present)
present since release_candidate_2013-10-28
https://github.com/splitbrain/dokuwiki/issues/1056
https://github.com/splitbrain/dokuwiki/commit/4970ad24ce49ec76a0ee67bca7594f918ced2f5f

Search for package or bug name: Reporting problems