CVE-2015-2188

NameCVE-2015-2188
Descriptionepan/dissectors/packet-wcp.c in the WCP dissector in Wireshark 1.10.x before 1.10.13 and 1.12.x before 1.12.4 does not properly initialize a data structure, which allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted packet that is improperly handled during decompression.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-198-1, DSA-3210-1
NVD severitymedium (attack range: remote)
Debian Bugs780372

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)wheezy1.8.2-5wheezy18fixed
wheezy (security)1.12.1+g01b65bf-4+deb8u6~deb7u7fixed
jessie (security), jessie1.12.1+g01b65bf-4+deb8u11fixed
stretch2.2.6+g32dac6a-2fixed
buster2.4.1-1fixed
sid2.4.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)1.12.1+g01b65bf-4medium780372
wiresharksourcesqueeze1.8.2-5wheezy15~deb6u1mediumDLA-198-1
wiresharksourcewheezy1.8.2-5wheezy15mediumDSA-3210-1

Notes

https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=10844
http://www.wireshark.org/security/wnpa-sec-2015-07.html
https://code.wireshark.org/review/gitweb?p=wireshark.git;a=commit;h=b204ff4846fe84b7789893c6b1d9afbdecac5b5d

Search for package or bug name: Reporting problems