CVE-2015-2206

NameCVE-2015-2206
Descriptionlibraries/select_lang.lib.php in phpMyAdmin 4.0.x before 4.0.10.9, 4.2.x before 4.2.13.2, and 4.3.x before 4.3.11.1 includes invalid language values in unknown-language error responses that contain a CSRF token and may be sent with HTTP compression, which makes it easier for remote attackers to conduct a BREACH attack and determine this token via a series of crafted requests.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-336-1, DSA-3382-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
phpmyadmin (PTS)wheezy4:3.4.11.1-2+deb7u2fixed
wheezy (security)4:3.4.11.1-2+deb7u8fixed
jessie (security), jessie4:4.2.12-2+deb8u2fixed
stretch4:4.6.6-4fixed
buster, sid4:4.6.6-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
phpmyadminsource(unstable)4:4.4.4-1unimportant
phpmyadminsourcejessie4:4.2.12-2+deb8u1mediumDSA-3382-1
phpmyadminsourcesqueeze4:3.3.7-9mediumDLA-336-1
phpmyadminsourcewheezy4:3.4.11.1-2+deb7u2mediumDSA-3382-1

Notes

Hardening, not a concrete issue itself
http://www.phpmyadmin.net/home_page/security/PMASA-2015-1.php

Search for package or bug name: Reporting problems