CVE-2015-2213

NameCVE-2015-2213
DescriptionSQL injection vulnerability in the wp_untrash_post_comments function in wp-includes/post.php in WordPress before 4.2.4 allows remote attackers to execute arbitrary SQL commands via a comment that is mishandled after retrieval from the trash.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-294-1, DSA-3332-1, DSA-3383-1
NVD severityhigh (attack range: remote)
Debian Bugs794560

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)wheezy3.6.1+dfsg-1~deb7u10fixed
wheezy (security)3.6.1+dfsg-1~deb7u16fixed
jessie4.1+dfsg-1+deb8u14fixed
jessie (security)4.1+dfsg-1+deb8u15fixed
stretch4.7.5+dfsg-2fixed
stretch (security)4.7.5+dfsg-2+deb9u1fixed
buster, sid4.8.2+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)4.2.4+dfsg-1high794560
wordpresssourcejessie4.1+dfsg-1+deb8u4highDSA-3332-1
wordpresssourcesqueeze3.6.1+dfsg-1~deb6u7highDLA-294-1
wordpresssourcewheezy3.6.1+dfsg-1~deb7u8highDSA-3383-1

Notes

https://core.trac.wordpress.org/changeset/33555
https://core.trac.wordpress.org/changeset/33556

Search for package or bug name: Reporting problems