CVE-2015-2221

NameCVE-2015-2221
DescriptionClamAV before 0.98.7 allows remote attackers to cause a denial of service (infinite loop) via a crafted y0da cryptor file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-233-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
clamav (PTS)wheezy0.99+dfsg-0+deb7u2fixed
wheezy (security)0.99.2+dfsg-0+deb7u3fixed
jessie0.99.2+dfsg-0+deb8u2fixed
stretch0.99.2+dfsg-6fixed
buster, sid0.99.3~beta1+dfsg-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
clamavsource(unstable)0.98.7+dfsg-1medium
clamavsourcejessie0.98.7+dfsg-0+deb8u1medium
clamavsourcesqueeze0.98.7+dfsg-0+deb6u1mediumDLA-233-1
clamavsourcewheezy0.98.7+dfsg-0+deb7u1medium

Notes

https://github.com/vrtadmin/clamav-devel/commit/0844d0cfe118b4041ed8e2ee49ff18bfbca8eaa5
https://github.com/vrtadmin/clamav-devel/commit/26b19809fb3b940cb0fda0422d685fff02a53b5f

Search for package or bug name: Reporting problems