CVE-2015-2241

NameCVE-2015-2241
DescriptionCross-site scripting (XSS) vulnerability in the contents function in admin/helpers.py in Django before 1.7.6 and 1.8 before 1.8b2 allows remote attackers to inject arbitrary web script or HTML via a model attribute in ModelAdmin.readonly_fields, as demonstrated by a @property.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-django (PTS)buster1:1.11.29-1~deb10u1fixed
buster (security)1:1.11.29-1+deb10u11fixed
bullseye (security), bullseye2:2.2.28-1~deb11u2fixed
bookworm, bookworm (security)3:3.2.19-1+deb12u1fixed
sid, trixie3:4.2.13-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-djangosourcesqueeze(not affected)
python-djangosourcewheezy(not affected)
python-djangosource(unstable)1.7.6-1

Notes

[wheezy] - python-django <not-affected> (Only affects 1.7.x and 1.8.x)
[squeeze] - python-django <not-affected> (Only affects 1.7.x and 1.8.x)
https://www.djangoproject.com/weblog/2015/mar/09/security-releases/

Search for package or bug name: Reporting problems