CVE-2015-2304

NameCVE-2015-2304
DescriptionAbsolute path traversal vulnerability in bsdcpio in libarchive 3.1.2 and earlier allows remote attackers to write to arbitrary files via a full pathname in an archive.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-166-1, DSA-3180-1
NVD severitymedium (attack range: remote)
Debian Bugs778266

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libarchive (PTS)wheezy3.0.4-3+wheezy1fixed
wheezy (security)3.0.4-3+wheezy6+deb7u1fixed
jessie (security), jessie3.1.2-11+deb8u3fixed
stretch3.2.2-2fixed
buster, sid3.2.2-3.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libarchivesource(unstable)3.1.2-11medium778266
libarchivesourcesqueeze2.8.4.forreal-1+squeeze3mediumDLA-166-1
libarchivesourcewheezy3.0.4-3+wheezy1mediumDSA-3180-1

Notes

http://www.openwall.com/lists/oss-security/2015/01/16/7
Patch: https://github.com/libarchive/libarchive/commit/59357157706d47c365b2227739e17daba3607526

Search for package or bug name: Reporting problems