CVE-2015-2317

NameCVE-2015-2317
DescriptionThe utils.http.is_safe_url function in Django before 1.4.20, 1.5.x, 1.6.x before 1.6.11, 1.7.x before 1.7.7, and 1.8.x before 1.8c1 does not properly validate URLs, which allows remote attackers to conduct cross-site scripting (XSS) attacks via a control character in a URL, as demonstrated by a \x08javascript: URL.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-272-1, DSA-3204-1
NVD severitymedium (attack range: remote)
Debian Bugs780873

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-django (PTS)wheezy1.4.5-1+deb7u16fixed
wheezy (security)1.4.22-1+deb7u3fixed
jessie (security), jessie1.7.11-1+deb8u2fixed
stretch1:1.10.7-2fixed
buster, sid1:1.11.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-djangosource(unstable)1.7.7-1medium780873
python-djangosourcesqueeze1.2.3-3+squeeze13mediumDLA-272-1
python-djangosourcewheezy1.4.5-1+deb7u11mediumDSA-3204-1

Notes

[squeeze] - python-django <no-dsa> (Minor issue, can wait next security upload)
https://github.com/django/django/commit/2342693b31f740a422abf7267c53b4e7bc487c1b (1.4.x)
https://github.com/django/django/commit/2a4113dbd532ce952308992633d802dc169a75f1 (1.7.x)

Search for package or bug name: Reporting problems