CVE-2015-2325

NameCVE-2015-2325
DescriptionThe compile_branch function in PCRE before 8.37 allows context-dependent attackers to compile incorrect code, cause a denial of service (out-of-bounds heap read and crash), or possibly have other unspecified impact via a regular expression with a group containing a forward reference repeated a large number of times within a repeated outer group that has a zero minimum quantifier.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs781795

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pcre3 (PTS)stretch2:8.39-3fixed
buster2:8.39-12fixed
bullseye, sid2:8.39-13fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pcre3sourcejessie2:8.35-3.3+deb8u1
pcre3source(unstable)2:8.35-7.2unimportant781795

Notes

http://bugs.exim.org/show_bug.cgi?id=1591
Fixed by: http://vcs.pcre.org/pcre?view=revision&revision=1528
Reproducer leads to "Failed: internal error: previously-checked referenced subpattern not found at offset 17"
Upstream claims that it should though be the same bug:
http://bugs.exim.org/show_bug.cgi?id=1591#c1
Comment from upstream: Probably every version since the support for forward referencing
was introduced is affected.

Search for package or bug name: Reporting problems