CVE-2015-2326

NameCVE-2015-2326
DescriptionThe pcre_compile2 function in PCRE before 8.37 allows context-dependent attackers to compile incorrect code and cause a denial of service (out-of-bounds read) via regular expression with a group containing both a forward referencing subroutine call and a recursive back reference, as demonstrated by "((?+1)(\1))/".
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs783285

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pcre3 (PTS)stretch2:8.39-3fixed
buster2:8.39-12fixed
bullseye, sid2:8.39-13fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pcre3sourcesqueeze(not affected)
pcre3sourcewheezy(not affected)
pcre3sourcejessie2:8.35-3.3+deb8u1
pcre3source(unstable)2:8.35-7.2783285

Notes

[wheezy] - pcre3 <not-affected> (Vulnerable code introuced while refactoring between 8.33 and 8.36)
[squeeze] - pcre3 <not-affected> (Vulnerable code introuced while refactoring between 8.33 and 8.36)
http://bugs.exim.org/show_bug.cgi?id=1592
http://vcs.pcre.org/pcre?view=revision&revision=1529
Reproduced invalid read in pcre3/2:8.35-3.3
Issue introduced as a side effect of refactoring happened between 8.33 and 8.36

Search for package or bug name: Reporting problems