CVE-2015-2328

NameCVE-2015-2328
DescriptionPCRE before 8.36 mishandles the /((?(R)a|(?1)))+/ pattern and related patterns with certain recursion, which allows remote attackers to cause a denial of service (segmentation fault) or possibly have unspecified other impact via a crafted regular expression, as demonstrated by a JavaScript RegExp object encountered by Konqueror.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mongodb (PTS)wheezy1:2.0.6-1.1vulnerable
wheezy (security)1:2.0.6-1.1+deb7u1vulnerable
jessie1:2.4.10-5+deb8u1vulnerable
stretch1:3.2.11-2+deb9u1vulnerable
buster, sid1:3.4.14-3vulnerable
pcre3 (PTS)wheezy1:8.30-5vulnerable
jessie2:8.35-3.3+deb8u4fixed
stretch2:8.39-3fixed
buster, sid2:8.39-9fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mongodbsource(unstable)(unfixed)unimportant
pcre3source(unstable)2:8.35-7.2low
pcre3sourcejessie2:8.35-3.3+deb8u2high

Notes

CVE for bundled version of pcre3 in mongodb
https://jira.mongodb.org/browse/SERVER-17252
Since 1:2.0.0-1 mongodb uses the system pcre3
[wheezy] - pcre3 <no-dsa> (Minor issue)
[squeeze] - pcre3 <no-dsa> (Minor issue)
https://bugs.exim.org/show_bug.cgi?id=1515
Fixed by: http://vcs.pcre.org/pcre?view=revision&revision=1498
http://www.openwall.com/lists/oss-security/2015/05/31/4

Search for package or bug name: Reporting problems