CVE-2015-2331

NameCVE-2015-2331
DescriptionInteger overflow in the _zip_cdir_new function in zip_dirent.c in libzip 0.11.2 and earlier, as used in the ZIP extension in PHP before 5.4.39, 5.5.x before 5.5.23, and 5.6.x before 5.6.7 and other products, allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a ZIP archive that contains many entries, leading to a heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-212-1, DSA-3198-1
NVD severityhigh (attack range: remote)
Debian Bugs780713, 780756

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libzip (PTS)wheezy0.10.1-1.1fixed
jessie0.11.2-1.2fixed
buster, sid, stretch1.1.2-1.1fixed
php5 (PTS)wheezy5.4.45-0+deb7u2fixed
wheezy (security)5.4.45-0+deb7u11fixed
jessie (security), jessie5.6.30+dfsg-0+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libzipsource(unstable)0.11.2-1.2high780756
libzipsourcesqueeze(not affected)
libzipsourcewheezy(not affected)
php5source(unstable)5.6.7+dfsg-1high780713
php5sourcesqueeze5.3.3.1-7+squeeze26highDLA-212-1
php5sourcewheezy5.4.39-0+deb7u1highDSA-3198-1

Notes

[wheezy] - libzip <not-affected> (Vulnerable code introduced with added Zip64 support in 0.11)
[squeeze] - libzip <not-affected> (Vulnerable code introduced with added Zip64 support in 0.11)
https://bugs.php.net/bug.php?id=69253
https://github.com/php/php-src/commit/ef8fc4b53d92fbfcd8ef1abbd6f2f5fe2c4a11e5
http://www.openwall.com/lists/oss-security/2015/03/18/1
libzip patch: http://hg.nih.at/libzip/rev/9f11d54f692e

Search for package or bug name: Reporting problems