CVE-2015-2665

NameCVE-2015-2665
DescriptionCross-site scripting (XSS) vulnerability in Cacti before 0.8.8d allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-255-1, DSA-3295-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cacti (PTS)stretch (security), stretch0.8.8h+ds1-10+deb9u1fixed
buster1.2.2+ds1-2+deb10u4fixed
buster (security)1.2.2+ds1-2+deb10u2fixed
bullseye, sid1.2.16+ds1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cactisourcesqueeze0.8.7g-1+squeeze6DLA-255-1
cactisourcewheezy0.8.8a+dfsg-5+deb7u5DSA-3295-1
cactisourcejessie0.8.8b+dfsg-8+deb8u1DSA-3295-1
cactisource(unstable)0.8.8d+ds1-1

Notes

http://www.fortiguard.com/advisory/FG-VD-15-017/
http://bugs.cacti.net/view.php?id=2542 (bug is not yet accessible)
http://svn.cacti.net/viewvc/cacti/tags/0.8.8d/graphs.php?r1=7716&r2=7717&view=patch

Search for package or bug name: Reporting problems