CVE-2015-2684

NameCVE-2015-2684
DescriptionShibboleth Service Provider (SP) before 2.5.4 allows remote authenticated users to cause a denial of service (crash) via a crafted SAML message.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-259-1, DSA-3207-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
shibboleth-sp2 (PTS)wheezy, wheezy (security)2.4.3+dfsg-5+deb7u1fixed
jessie2.5.3+dfsg-2fixed
stretch2.6.0+dfsg1-4fixed
buster, sid2.6.0+dfsg1-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
shibboleth-sp2source(unstable)2.5.3+dfsg-2medium
shibboleth-sp2sourcesqueeze2.3.1+dfsg-5+deb6u1mediumDLA-259-1
shibboleth-sp2sourcewheezy2.4.3+dfsg-5+deb7u1mediumDSA-3207-1

Notes

http://shibboleth.net/community/advisories/secadv_20150319.txt

Search for package or bug name: Reporting problems