CVE-2015-2694

NameCVE-2015-2694
DescriptionThe kdcpreauth modules in MIT Kerberos 5 (aka krb5) 1.12.x and 1.13.x before 1.13.2 do not properly track whether a client's request has been validated, which allows remote attackers to bypass an intended preauthentication requirement by providing (1) zero bytes of data or (2) an arbitrary realm name, related to plugins/preauth/otp/main.c and plugins/preauth/pkinit/pkinit_srv.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs783557

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
krb5 (PTS)jessie1.12.1+dfsg-19+deb8u4fixed
jessie (security)1.12.1+dfsg-19+deb8u5fixed
stretch1.15-1+deb9u1fixed
buster1.17-3fixed
bullseye, sid1.17-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
krb5source(unstable)1.12.1+dfsg-20medium783557
krb5sourcejessie1.12.1+dfsg-19+deb8u3medium

Notes

[wheezy] - krb5 <no-dsa> (Minor issue and can be fixed in a future DSA)
[squeeze] - krb5 <no-dsa> (Minor issue and can be fixed in a future DSA)
Upstream ticket: http://krbdev.mit.edu/rt/Ticket/Display.html?id=8160
Upstream commit: https://github.com/krb5/krb5/commit/e3b5a5e5267818c97750b266df50b6a3d4649604
wheezy marked as no-dsa since OTP plugin not present. But the issue
might affect any out-of-tree plugins with similar bug as the OTP
has. Thus basicaly only krb5/1.12 is affected.

Search for package or bug name: Reporting problems