CVE-2015-2695

NameCVE-2015-2695
Descriptionlib/gssapi/spnego/spnego_mech.c in MIT Kerberos 5 (aka krb5) before 1.14 relies on an inappropriate context handle, which allows remote attackers to cause a denial of service (incorrect pointer read and process crash) via a crafted SPNEGO packet that is mishandled during a gss_inquire_context call.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-340-1, DSA-3395-1
NVD severityhigh (attack range: remote)
Debian Bugs803083

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
krb5 (PTS)wheezy1.10.1+dfsg-5+deb7u7fixed
wheezy (security)1.10.1+dfsg-5+deb7u8fixed
jessie (security), jessie1.12.1+dfsg-19+deb8u2fixed
stretch1.15-1+deb9u1fixed
buster, sid1.15.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
krb5source(unstable)1.13.2+dfsg-3high803083
krb5sourcejessie1.12.1+dfsg-19+deb8u1highDSA-3395-1
krb5sourcesqueeze1.8.3+dfsg-4squeeze10highDLA-340-1
krb5sourcewheezy1.10.1+dfsg-5+deb7u4highDSA-3395-1

Notes

https://github.com/krb5/krb5/commit/b51b33f2bc5d1497ddf5bd107f791c101695000d
Upstream ticket: http://krbdev.mit.edu/rt/Ticket/Display.html?id=8244

Search for package or bug name: Reporting problems