CVE-2015-2697

NameCVE-2015-2697
DescriptionThe build_principal_va function in lib/krb5/krb/bld_princ.c in MIT Kerberos 5 (aka krb5) before 1.14 allows remote authenticated users to cause a denial of service (out-of-bounds read and KDC crash) via an initial '\0' character in a long realm field within a TGS request.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-340-1, DSA-3395-1, DSA-3395-2
NVD severitymedium (attack range: remote)
Debian Bugs803088

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
krb5 (PTS)wheezy1.10.1+dfsg-5+deb7u7fixed
wheezy (security)1.10.1+dfsg-5+deb7u8fixed
jessie1.12.1+dfsg-19+deb8u4fixed
jessie (security)1.12.1+dfsg-19+deb8u2fixed
stretch1.15-1+deb9u1fixed
buster, sid1.15.2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
krb5source(unstable)1.13.2+dfsg-3medium803088
krb5sourcejessie1.12.1+dfsg-19+deb8u1mediumDSA-3395-1
krb5sourcesqueeze1.8.3+dfsg-4squeeze10mediumDLA-340-1
krb5sourcewheezy1.10.1+dfsg-5+deb7u6mediumDSA-3395-2

Notes

https://github.com/krb5/krb5/commit/f0c094a1b745d91ef2f9a4eae2149aac026a5789
Upstream ticket: http://krbdev.mit.edu/rt/Ticket/Display.html?id=8252

Search for package or bug name: Reporting problems