CVE-2015-2716

NameCVE-2015-2716
DescriptionBuffer overflow in the XML parser in Mozilla Firefox before 38.0, Firefox ESR 31.x before 31.7, and Thunderbird before 31.7 allows remote attackers to execute arbitrary code by providing a large amount of compressed XML data, a related issue to CVE-2015-1283.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3260-1, DSA-3264-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icedove (PTS)wheezy38.7.0-1~deb7u1fixed
wheezy (security)1:52.3.0-4~deb7u2fixed
jessie1:45.8.0-3~deb8u1fixed
jessie (security)1:52.3.0-4~deb8u2fixed
stretch (security), stretch1:52.3.0-4~deb9u1fixed
buster, sid1:52.3.0-4fixed
iceweasel (PTS)wheezy, wheezy (security)38.8.0esr-1~deb7u1fixed
jessie (security)38.8.0esr-1~deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
icedovesource(unstable)31.7.0-1high
icedovesourcejessie31.7.0-1~deb8u1highDSA-3264-1
icedovesourcesqueeze(unfixed)end-of-life
icedovesourcewheezy31.7.0-1~deb7u1highDSA-3264-1
iceweaselsource(unstable)38.0-1high
iceweaselsourcejessie31.7.0esr-1~deb8u1highDSA-3260-1
iceweaselsourcesqueeze(unfixed)end-of-life
iceweaselsourcewheezy31.7.0esr-1~deb7u1highDSA-3260-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2015-54/

Search for package or bug name: Reporting problems