CVE-2015-2730

NameCVE-2015-2730
DescriptionMozilla Network Security Services (NSS) before 3.19.1, as used in Mozilla Firefox before 39.0, Firefox ESR 31.x before 31.8 and 38.x before 38.1, and other products, does not properly perform Elliptical Curve Cryptography (ECC) multiplications, which makes it easier for remote attackers to spoof ECDSA signatures via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-315-1, DSA-3336-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
iceweasel (PTS)wheezy, wheezy (security)38.8.0esr-1~deb7u1fixed
jessie (security)38.8.0esr-1~deb8u1fixed
nss (PTS)wheezy2:3.14.5-1+deb7u5fixed
wheezy (security)2:3.26-1+debu7u5fixed
jessie2:3.26-1+debu8u2fixed
jessie (security)2:3.26-1+debu8u3fixed
stretch2:3.26.2-1.1fixed
stretch (security)2:3.26.2-1.1+deb9u1fixed
buster, sid2:3.33-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceweaselsource(unstable)38.1.0esr-1medium
iceweaselsourcejessie(not affected)
iceweaselsourcesqueeze(unfixed)end-of-life
iceweaselsourcewheezy(not affected)
nsssource(unstable)2:3.19.1-1medium
nsssourcejessie2:3.17.2-1.1+deb8u1mediumDSA-3336-1
nsssourcesqueeze3.12.8-1+squeeze12mediumDLA-315-1
nsssourcewheezy2:3.14.5-1+deb7u5mediumDSA-3336-1

Notes

[jessie] - iceweasel <not-affected> (Only affects Firefox 38 and later)
[wheezy] - iceweasel <not-affected> (Only affects Firefox 38 and later)
https://www.mozilla.org/en-US/security/advisories/mfsa2015-64/
https://hg.mozilla.org/projects/nss/rev/fc6870938172
https://hg.mozilla.org/projects/nss/rev/2c05e861ce07

Search for package or bug name: Reporting problems