CVE-2015-2756

NameCVE-2015-2756
DescriptionQEMU, as used in Xen 3.3.x through 4.5.x, does not properly restrict access to PCI command registers, which might allow local HVM guest users to cause a denial of service (non-maskable interrupt and host crash) by disabling the (1) memory or (2) I/O decoding for a PCI Express device and then accessing the device, which triggers an Unsupported Request (UR) response.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-479-1, DSA-3259-1
NVD severitymedium
Debian Bugs781620

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)stretch1:2.8+dfsg-6+deb9u9fixed
stretch (security)1:2.8+dfsg-6+deb9u11fixed
buster, buster (security)1:3.1+dfsg-8+deb10u8fixed
bullseye, sid1:5.1+dfsg-4fixed
xen (PTS)stretch (security), stretch4.8.5.final+shim4.10.4-1+deb9u12fixed
buster, buster (security)4.11.4+24-gddaaccbbab-1~deb10u1fixed
bullseye, sid4.11.4+24-gddaaccbbab-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusourcesqueeze(not affected)
qemusourcewheezy(not affected)
qemusourcejessie1:2.1+dfsg-12DSA-3259-1
qemusource(unstable)1:2.3+dfsg-3
qemu-kvmsource(unstable)(not affected)
xensourcesqueeze(unfixed)end-of-life
xensourcewheezy4.1.6.1-1+deb7u1DLA-479-1
xensource(unstable)4.2.0~rc2-1781620

Notes

[squeeze] - xen <end-of-life> (Not supported in Squeeze LTS)
[wheezy] - qemu <not-affected> (Vulnerable code not present)
[squeeze] - qemu <not-affected> (Vulnerable code not present)
- qemu-kvm <not-affected> (Vulnerable code not present)
http://xenbits.xen.org/xsa/advisory-126.html

Search for package or bug name: Reporting problems