CVE-2015-2778

NameCVE-2015-2778
DescriptionQuassel before 0.12-rc1 uses an incorrect data-type size when splitting a message, which allows remote attackers to cause a denial of service (crash) via a long CTCP query containing only multibyte characters.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs781024

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
quassel (PTS)stretch (security), stretch1:0.12.4-2+deb9u1fixed
buster1:0.13.1-1+deb10u2fixed
bullseye1:0.13.1-5fixed
bookworm, sid1:0.14.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
quasselsourcesqueeze(not affected)
quasselsourcewheezy(not affected)
quasselsource(unstable)1:0.10.0-2.3781024

Notes

[wheezy] - quassel <not-affected> (According to upstream issue isn't triggerable in 0.8)
[squeeze] - quassel <not-affected> (According to upstream issue isn't triggerable in 0.6)
https://github.com/quassel/quassel/commit/b5e38970ffd55e2dd9f706ce75af9a8d7730b1b8
https://www.openwall.com/lists/oss-security/2015/03/20/12

Search for package or bug name: Reporting problems