CVE-2015-2831

NameCVE-2015-2831
DescriptionBuffer overflow in das_watchdog 0.9.0 allows local users to execute arbitrary code with root privileges via a large string in the XAUTHORITY environment variable.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-194-1, DSA-3221-1
NVD severityhigh
Debian Bugs781806

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
das-watchdog (PTS)bullseye, sid, buster, stretch0.9.0-3.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
das-watchdogsourcesqueeze0.9.0-2+deb6u1DLA-194-1
das-watchdogsourcewheezy0.9.0-2+deb7u1DSA-3221-1
das-watchdogsource(unstable)0.9.0-3.1781806

Notes

Upstream commit: https://github.com/kmatheussen/das_watchdog/commit/bd20bb02e75e2c
https://www.openwall.com/lists/oss-security/2015/04/01/8

Search for package or bug name: Reporting problems