CVE-2015-2938

NameCVE-2015-2938
DescriptionCross-site scripting (XSS) vulnerability in MediaWiki before 1.19.24, 1.2x before 1.23.9, and 1.24.x before 1.24.2 allows remote attackers to inject arbitrary web script or HTML via a custom JavaScript file, which is not properly handled when previewing the file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mediawiki (PTS)stretch1:1.27.7-1~deb9u3fixed
stretch (security)1:1.27.7-1~deb9u5fixed
buster1:1.31.7-1~deb10u1fixed
buster (security)1:1.31.10-1~deb10u1fixed
bullseye, sid1:1.35.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mediawikisourcesqueeze(unfixed)end-of-life
mediawikisourcewheezy(unfixed)end-of-life
mediawikisource(unstable)1:1.19.20+dfsg-2.3

Notes

[wheezy] - mediawiki <end-of-life> (Not supported in Wheezy LTS)
[squeeze] - mediawiki <end-of-life> (Not supported in Squeeze LTS)
https://lists.wikimedia.org/pipermail/mediawiki-announce/2015-March/000175.html
https://www.openwall.com/lists/oss-security/2015/04/01/1

Search for package or bug name: Reporting problems