CVE-2015-2941

NameCVE-2015-2941
DescriptionCross-site scripting (XSS) vulnerability in MediaWiki before 1.19.24, 1.2x before 1.23.9, and 1.24.x before 1.24.2, when using HHVM, allows remote attackers to inject arbitrary web script or HTML via an invalid parameter in a wddx format request to api.php, which is not properly handled in an error message, related to unsafe calls to wddx_serialize_value.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mediawiki (PTS)stretch1:1.27.4-1~deb9u1fixed
stretch (security)1:1.27.5-1~deb9u1fixed
buster, sid1:1.31.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mediawikisource(unstable)1:1.19.20+dfsg-2.3unimportant

Notes

HHVM not packaged in Debian
https://lists.wikimedia.org/pipermail/mediawiki-announce/2015-March/000175.html
http://www.openwall.com/lists/oss-security/2015/04/01/1

Search for package or bug name: Reporting problems