CVE-2015-2942

NameCVE-2015-2942
DescriptionMediaWiki before 1.19.24, 1.2x before 1.23.9, and 1.24.x before 1.24.2, when using HHVM, allows remote attackers to cause a denial of service (CPU and memory consumption) via a large number of nested entity references in an (1) SVG file or (2) XMP metadata in a PDF file, aka a "billion laughs attack," a different vulnerability than CVE-2015-2937.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mediawiki (PTS)wheezy, wheezy (security)1:1.19.20+dfsg-0+deb7u3vulnerable
stretch (security), stretch1:1.27.4-1~deb9u1fixed
buster, sid1:1.30.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mediawikisource(unstable)1:1.19.20+dfsg-2.3unimportant

Notes

HHVM not packaged in Debian
https://lists.wikimedia.org/pipermail/mediawiki-announce/2015-March/000175.html
http://www.openwall.com/lists/oss-security/2015/04/01/1

Search for package or bug name: Reporting problems