CVE-2015-3012

NameCVE-2015-3012
DescriptionMultiple cross-site scripting (XSS) vulnerabilities in WebODF before 0.5.5, as used in ownCloud, allow remote attackers to inject arbitrary web script or HTML via a (1) style or (2) font name or (3) javascript or (4) data URI.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3244-1
NVD severitymedium (attack range: remote)
Debian Bugs727529

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
owncloud (PTS)jessie (security)7.0.4+dfsg-4~deb8u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
owncloudsource(unstable)7.0.4+dfsg-3medium
owncloudsourceexperimental7.0.5+dfsg-1medium
owncloudsourcejessie7.0.4+dfsg-4~deb8u1mediumDSA-3244-1
owncloud-documentssource(unstable)(not affected)
webodfITP727529

Notes

- owncloud-documents <not-affected> (Fixed before initial release to Debian)
https://owncloud.org/security/advisory/?id=oc-sa-2015-002

Search for package or bug name: Reporting problems