CVE-2015-3143

NameCVE-2015-3143
DescriptioncURL and libcurl 7.10.6 through 7.41.0 does not properly re-use NTLM connections, which allows remote attackers to connect as other users via an unauthenticated request, a similar issue to CVE-2014-0015.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-211-1, DSA-3232-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
curl (PTS)stretch7.52.1-5+deb9u10fixed
stretch (security)7.52.1-5+deb9u11fixed
buster, buster (security)7.64.0-4+deb10u1fixed
bullseye, sid7.72.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
curlsourcesqueeze7.21.0-2.1+squeeze12DLA-211-1
curlsourcewheezy7.26.0-1+wheezy13DSA-3232-1
curlsourcejessie7.38.0-4+deb8u1DSA-3232-1
curlsource(unstable)7.42.0-1

Notes

http://curl.haxx.se/docs/adv_20150422A.html

Search for package or bug name: Reporting problems