CVE-2015-3146

NameCVE-2015-3146
DescriptionThe (1) SSH_MSG_NEWKEYS and (2) SSH_MSG_KEXDH_REPLY packet handlers in package_cb.c in libssh before 0.6.5 do not properly validate state, which allows remote attackers to cause a denial of service (NULL pointer dereference and crash) via a crafted SSH packet.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs784404

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libssh (PTS)wheezy, wheezy (security)0.5.4-1+deb7u3fixed
jessie (security), jessie0.6.3-4+deb8u2fixed
stretch0.7.3-2fixed
buster, sid0.8.0~20170825.94fa1e38-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libsshsource(unstable)0.6.3-4.2medium784404
libsshsourcejessie0.6.3-4+deb8u1medium
libsshsourcesqueeze(not affected)
libsshsourcewheezy0.5.4-1+deb7u3medium

Notes

[squeeze] - libssh <not-affected> (Issue only present in versions > 0.5.1, squeeze has 0.4.5)
https://www.libssh.org/2015/04/30/libssh-0-6-5-security-and-bugfix-release/

Search for package or bug name: Reporting problems