CVE-2015-3152

NameCVE-2015-3152
DescriptionOracle MySQL before 5.7.3, Oracle MySQL Connector/C (aka libmysqlclient) before 6.1.3, and MariaDB before 5.5.44 use the --ssl option to mean that SSL is optional, which allows man-in-the-middle attackers to spoof servers via a cleartext-downgrade attack, aka a "BACKRONYM" attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3311-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mariadb-10.0 (PTS)jessie10.0.30-0+deb8u2fixed
jessie (security)10.0.32-0+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mariadb-10.0source(unstable)10.0.20-1medium
mariadb-10.0sourcejessie10.0.20-0+deb8u1mediumDSA-3311-1
percona-xtradb-cluster-5.5source(unstable)(unfixed)medium

Notes

CVE was assigned explicitly only for MariaDB and Percona, but not Oracle MySQL
since Oracle is a CNA itself.
http://www.ocert.org/advisories/ocert-2015-003.html
http://mysqlblog.fivefarmers.com/2015/04/29/ssltls-in-5-6-and-5-5-ocert-advisory/
https://mariadb.atlassian.net/browse/MDEV-7937

Search for package or bug name: Reporting problems