CVE-2015-3182

NameCVE-2015-3182
Descriptionepan/dissectors/packet-dec-dnart.c in the DECnet NSP/RT dissector in Wireshark 1.10.12 through 1.10.14 mishandles a certain strdup return value, which allows remote attackers to cause a denial of service (application crash) via a crafted packet.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)jessie1.12.1+g01b65bf-4+deb8u14fixed
jessie (security)1.12.1+g01b65bf-4+deb8u19fixed
stretch (security), stretch2.6.7-1~deb9u1fixed
buster2.6.8-1.1fixed
bullseye3.2.1-1fixed
sid3.2.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)1.12.0~rc1-1
wiresharksourcejessie(not affected)
wiresharksourcesqueeze(not affected)
wiresharksourcewheezy(not affected)

Notes

[jessie] - wireshark <not-affected> (Only affected 1.10.x)
[wheezy] - wireshark <not-affected> (Only affected 1.10.x)
[squeeze] - wireshark <not-affected> (Only affected 1.10.x)
https://www.wireshark.org/security/wnpa-sec-2015-01.html
https://bugzilla.redhat.com/show_bug.cgi?id=1219409

Search for package or bug name: Reporting problems