CVE-2015-3184

NameCVE-2015-3184
Descriptionmod_authz_svn in Apache Subversion 1.7.x before 1.7.21 and 1.8.x before 1.8.14, when using Apache httpd 2.4.x, does not properly restrict anonymous access, which allows remote anonymous users to read hidden files via the path name.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3331-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
subversion (PTS)wheezy1.6.17dfsg-4+deb7u10fixed
wheezy (security)1.6.17dfsg-4+deb7u12fixed
jessie (security), jessie1.8.10-6+deb8u5fixed
stretch (security), stretch1.9.5-1+deb9u1fixed
buster, sid1.9.7-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
subversionsource(unstable)1.9.0-1medium
subversionsourcejessie1.8.10-6+deb8u1mediumDSA-3331-1
subversionsourcesqueeze(not affected)
subversionsourcewheezy1.6.17dfsg-4+deb7u10mediumDSA-3331-1

Notes

[wheezy] - subversion <not-affected> (1.6 does not build with apache 2.4)
[squeeze] - subversion <not-affected> (1.6 does not build with apache 2.4)
https://subversion.apache.org/security/CVE-2015-3184-advisory.txt
subversion needs to be built with a fixed apache version

Search for package or bug name: Reporting problems