|Description||The ap_some_auth_required function in server/request.c in the Apache HTTP Server 2.4.x before 2.4.14 does not consider that a Require directive may be associated with an authorization setting rather than an authentication setting, which allows remote attackers to bypass intended access restrictions in opportunistic circumstances by leveraging the presence of a module that relies on the 2.2 API behavior.|
|Source||CVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)|
Vulnerable and fixed packages
The table below lists information on source packages.
|stretch (security), stretch||2.4.25-3+deb9u9||fixed|
|buster, buster (security)||2.4.38-3+deb10u3||fixed|
The information below is based on the following data on fixed versions.
[wheezy] - apache2 <not-affected> (Bug introduced during 2.4 development)
[squeeze] - apache2 <not-affected> (Bug introduced during 2.4 development)
Behavior changed in 2.4.x refactoring, API no longer usable in 2.4.x