DescriptionThe ap_some_auth_required function in server/request.c in the Apache HTTP Server 2.4.x before 2.4.14 does not consider that a Require directive may be associated with an authorization setting rather than an authentication setting, which allows remote attackers to bypass intended access restrictions in opportunistic circumstances by leveraging the presence of a module that relies on the 2.2 API behavior.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apache2 (PTS)wheezy2.2.22-13+deb7u6fixed
wheezy (security)2.2.22-13+deb7u12fixed
jessie (security), jessie2.4.10-10+deb8u11fixed
stretch (security), stretch2.4.25-3+deb9u3fixed
buster, sid2.4.29-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apache2sourcesqueeze(not affected)


[wheezy] - apache2 <not-affected> (Bug introduced during 2.4 development)
[squeeze] - apache2 <not-affected> (Bug introduced during 2.4 development)
Behavior changed in 2.4.x refactoring, API no longer usable in 2.4.x

Search for package or bug name: Reporting problems