CVE-2015-3204

NameCVE-2015-3204
Descriptionlibreswan 3.9 through 3.12 allows remote attackers to cause a denial of service (daemon restart) via an IKEv1 packet with (1) unassigned bits set in the IPSEC DOI value or (2) the next payload value set to ISAKMP_NEXT_SAK.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libreswan (PTS)buster3.27-6fixed
bullseye, sid3.29-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libreswansource(unstable)(not affected)

Notes

- libreswan <not-affected> (Fixed before the initial upload to Debian)
https://libreswan.org/security/CVE-2015-3204/CVE-2015-3204.txt
https://libreswan.org/security/CVE-2015-3204/CVE-2015-3204-libreswan.patch

Search for package or bug name: Reporting problems