CVE-2015-3210

NameCVE-2015-3210
DescriptionHeap-based buffer overflow in PCRE 8.34 through 8.37 and PCRE2 10.10 allows remote attackers to execute arbitrary code via a crafted regular expression, as demonstrated by /^(?P=B)((?P=B)(?J:(?P<B>c)(?P<B>a(?P=B)))>WGXCREDITS)/, a different vulnerability than CVE-2015-8384.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs787433

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pcre3 (PTS)jessie2:8.35-3.3+deb8u4fixed
stretch2:8.39-3fixed
bullseye, buster, sid2:8.39-12fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pcre3source(unstable)2:8.35-7.2high787433
pcre3sourcejessie2:8.35-3.3+deb8u1high
pcre3sourcesqueeze(not affected)
pcre3sourcewheezy(not affected)

Notes

[wheezy] - pcre3 <not-affected> (Vulnerable code introduced later)
[squeeze] - pcre3 <not-affected> (Vulnerable code introduced later)
https://bugs.exim.org/show_bug.cgi?id=1636
Fixed by: http://vcs.pcre.org/pcre?view=revision&revision=1558
Affected code refactored in: http://vcs.pcre.org/pcre?view=revision&revision=1359 (8.34)
Issue then introduced by: http://vcs.pcre.org/pcre?view=revision&revision=1361

Search for package or bug name: Reporting problems