CVE-2015-3214

NameCVE-2015-3214
DescriptionThe pit_ioport_read in i8254.c in the Linux kernel before 2.6.33 and QEMU before 2.3.1 does not distinguish between read lengths and write lengths, which might allow guest OS users to execute arbitrary code on the host OS by triggering use of an invalid index.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3348-1
NVD severitymedium (attack range: local)
Debian Bugs795461

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)wheezy3.2.78-1fixed
wheezy (security)3.2.93-1fixed
jessie3.16.43-2+deb8u2fixed
jessie (security)3.16.43-2+deb8u5fixed
stretch4.9.51-1fixed
stretch (security)4.9.30-2+deb9u5fixed
buster, sid4.13.13-1fixed
qemu (PTS)wheezy1.1.2+dfsg-6a+deb7u12fixed
wheezy (security)1.1.2+dfsg-6+deb7u24fixed
jessie (security), jessie1:2.1+dfsg-12+deb8u6fixed
stretch1:2.8+dfsg-6+deb9u2fixed
stretch (security)1:2.8+dfsg-6+deb9u3fixed
buster, sid1:2.10.0+dfsg-2fixed
qemu-kvm (PTS)wheezy1.1.2+dfsg-6+deb7u12fixed
wheezy (security)1.1.2+dfsg-6+deb7u24fixed
xen (PTS)wheezy4.1.4-3+deb7u9fixed
wheezy (security)4.1.6.lts1-10fixed
jessie4.4.1-9+deb8u9fixed
jessie (security)4.4.1-9+deb8u10fixed
buster, stretch (security), stretch, sid4.8.1-1+deb9u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)(not affected)
linux-2.6source(unstable)2.6.37-1medium
qemusource(unstable)1:2.4+dfsg-1amedium795461
qemusourcejessie1:2.1+dfsg-12+deb8u2mediumDSA-3348-1
qemusourcesqueeze(not affected)
qemusourcewheezy(not affected)
qemu-kvmsource(unstable)(not affected)
xensource(unstable)4.4.0-1medium
xensourcewheezy(not affected)

Notes

[wheezy] - qemu <not-affected> (Introduced in 1.3.0)
[squeeze] - qemu <not-affected> (Introduced in 1.3.0)
- qemu-kvm <not-affected> (Introduced in 1.3.0)
[wheezy] - xen <not-affected> (Vulnerable code introduced in 1.3.0, embedded version is 0.10.2)
Xen switched to qemu-system in 4.4.0-1
Upstream commit: http://git.qemu.org/?p=qemu.git;a=commitdiff;h=d4862a87e31a51de9eb260f25c9e99a75efe3235
Introduced in http://git.qemu.org/?p=qemu.git;a=commitdiff;h=0505bcdec8228d8de39ab1a02644e71999e7c052 (v1.3.0-rc0)
- linux <not-affected> (Fixed before linux-2.6 -> linux rename, v2.6.33-rc8)
[squeeze] - linux-2.6 <no-dsa> (KVM not supported in Squeeze LTS)
Upstream commit: https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=ee73f656a604d5aa9df86a97102e4e462dd79924 (v2.6.33-rc8)

Search for package or bug name: Reporting problems