CVE-2015-3217

NameCVE-2015-3217
DescriptionPCRE 7.8 and 8.32 through 8.37, and PCRE2 10.10 mishandle group empty matches, which might allow remote attackers to cause a denial of service (stack-based buffer overflow) via a crafted regular expression, as demonstrated by /^(?:(?(1)\\.|([^\\\\W_])?)+)+$/.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs787641

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pcre3 (PTS)jessie2:8.35-3.3+deb8u4vulnerable
stretch2:8.39-3fixed
buster, sid2:8.39-12fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pcre3source(unstable)2:8.38-1medium787641

Notes

[jessie] - pcre3 <no-dsa> (Minor issue)
[wheezy] - pcre3 <no-dsa> (Minor issue)
[squeeze] - pcre3 <no-dsa> (Minor issue)
https://bugs.exim.org/show_bug.cgi?id=1638
Upstream fix: http://vcs.pcre.org/pcre?view=revision&revision=1566
More information: https://bugzilla.redhat.com/show_bug.cgi?id=1228283#c2

Search for package or bug name: Reporting problems