CVE-2015-3218

NameCVE-2015-3218
DescriptionThe authentication_agent_new function in polkitbackend/polkitbackendinteractiveauthority.c in PolicyKit (aka polkit) before 0.113 allows local users to cause a denial of service (NULL pointer dereference and polkitd daemon crash) by calling RegisterAuthenticationAgent with an invalid object path.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow (attack range: local)
Debian Bugs787932

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
policykit-1 (PTS)jessie0.105-15~deb8u2fixed
jessie (security)0.105-15~deb8u4fixed
stretch (security), stretch0.105-18+deb9u1fixed
bullseye, sid, buster0.105-25fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
policykit-1source(unstable)0.105-11low787932
policykit-1sourceexperimental0.113-1low
policykit-1sourcejessie0.105-15~deb8u1low
policykit-1sourcesqueeze(not affected)

Notes

[wheezy] - policykit-1 <no-dsa> (Minor issue)
[squeeze] - policykit-1 <not-affected> (Vulnerable code introduced later)
http://lists.freedesktop.org/archives/polkit-devel/2015-May/000420.html
Patch: http://cgit.freedesktop.org/polkit/commit/?id=48e646918efb2bf0b3b505747655726d7869f31c
Introduced by: http://cgit.freedesktop.org/polkit/commit/?id=6eeb077bc90c9c7783360a526b2f04645b1b0848

Search for package or bug name: Reporting problems