CVE-2015-3219

NameCVE-2015-3219
DescriptionCross-site scripting (XSS) vulnerability in the Orchestration/Stack section in OpenStack Dashboard (Horizon) 2014.2 before 2014.2.4 and 2015.1.x before 2015.1.1 allows remote attackers to inject arbitrary web script or HTML via the description parameter in a heat template, which is not properly handled in the help_text attribute in the Field class.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3617-1
NVD severitymedium (attack range: remote)
Debian Bugs788306

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
horizon (PTS)wheezy2012.1.1-10fixed
wheezy (security)2012.1.1-10+deb7u1fixed
jessie (security), jessie2014.1.3-7+deb8u2fixed
sid, stretch3:10.0.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
horizonsource(unstable)2015.1.0+2015.06.09.git15.e63af6c598-1medium788306
horizonsourcejessie2014.1.3-7+deb8u2mediumDSA-3617-1
horizonsourcewheezy(not affected)

Notes

[wheezy] - horizon <not-affected> (Vulnerable code not present)
2014.2 versions through 2014.2.3 and version 2015.1.0

Search for package or bug name: Reporting problems