CVE-2015-3225

NameCVE-2015-3225
Descriptionlib/rack/utils.rb in Rack before 1.5.4 and 1.6.x before 1.6.2, as used with Ruby on Rails 3.x and 4.x and other products, allows remote attackers to cause a denial of service (SystemStackError) via a request with a large parameter depth.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-254-1, DSA-3322-1
NVD severitymedium (attack range: remote)
Debian Bugs789311

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-rack (PTS)wheezy, wheezy (security)1.4.1-2.1+deb7u1fixed
jessie (security), jessie1.5.2-3+deb8u1fixed
buster, sid, stretch1.6.4-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
librack-rubysource(unstable)(unfixed)medium
librack-rubysourcesqueeze1.1.0-4+squeeze3mediumDLA-254-1
ruby-racksource(unstable)1.5.2-4medium789311
ruby-racksourcejessie1.5.2-3+deb8u1mediumDSA-3322-1
ruby-racksourcewheezy1.4.1-2.1+deb7u1mediumDSA-3322-1
ruby-rack1.4source(unstable)(unfixed)medium

Notes

http://seclists.org/oss-sec/2015/q2/729 has patches for 1.5 and 1.6

Search for package or bug name: Reporting problems