CVE-2015-3227

NameCVE-2015-3227
DescriptionThe (1) jdom.rb and (2) rexml.rb components in Active Support in Ruby on Rails before 4.1.11 and 4.2.x before 4.2.2, when JDOM or REXML is enabled, allow remote attackers to cause a denial of service (SystemStackError) via a large XML document depth.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-603-1, DSA-3464-1
NVD severitymedium (attack range: remote)
Debian Bugs790487

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)wheezy2:2.3.14.2fixed
jessie (security), jessie2:4.1.8-1+deb8u4fixed
stretch2:4.2.7.1-1fixed
buster, sid2:4.2.9-4fixed
ruby-activesupport-2.3 (PTS)wheezy2.3.14-7vulnerable
ruby-activesupport-3.2 (PTS)wheezy3.2.6-6+deb7u1vulnerable
wheezy (security)3.2.6-6+deb7u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssource(unstable)2:4.2.4-2medium790487
railssourcejessie2:4.1.8-1+deb8u1mediumDSA-3464-1
railssourcesqueeze(unfixed)end-of-life
railssourcewheezy(not affected)
ruby-activesupport-2.3source(unstable)(unfixed)medium
ruby-activesupport-2.3sourcewheezy(unfixed)end-of-life
ruby-activesupport-3.2source(unstable)(unfixed)medium
ruby-activesupport-3.2sourcewheezy3.2.6-6+deb7u2mediumDLA-603-1

Notes

[squeeze] - rails <end-of-life> (Unsupported in squeeze-lts)
[wheezy] - rails <not-affected> (Vulnerable code not present, is only a transitional package)
[wheezy] - ruby-activesupport-2.3 <end-of-life> (https://lists.debian.org/debian-security-announce/2014/msg00164.html)

Search for package or bug name: Reporting problems