CVE-2015-3228

NameCVE-2015-3228
DescriptionInteger overflow in the gs_heap_alloc_bytes function in base/gsmalloc.c in Ghostscript 9.15 and earlier allows remote attackers to cause a denial of service (crash) via a crafted Postscript (ps) file, as demonstrated by using the ps2pdf command, which triggers an out-of-bounds read or write.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-280-1, DSA-3326-1
NVD severitymedium (attack range: remote)
Debian Bugs793489

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ghostscript (PTS)wheezy9.05~dfsg-6.3+deb7u2fixed
wheezy (security)9.05~dfsg-6.3+deb7u7fixed
jessie (security), jessie9.06~dfsg-2+deb8u6fixed
stretch (security), stretch9.20~dfsg-3.2+deb9u1fixed
buster, sid9.22~dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ghostscriptsource(unstable)9.15~dfsg-1medium793489
ghostscriptsourcejessie9.06~dfsg-2+deb8u1mediumDSA-3326-1
ghostscriptsourcesqueeze8.71~dfsg2-9+squeeze2mediumDLA-280-1
ghostscriptsourcewheezy9.05~dfsg-6.3+deb7u2mediumDSA-3326-1

Notes

http://bugs.ghostscript.com/show_bug.cgi?id=696070
http://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=0c0b0859
File to reproduce segfault with ps2pdf: http://bugs.ghostscript.com/attachment.cgi?id=11776

Search for package or bug name: Reporting problems