CVE-2015-3259

NameCVE-2015-3259
DescriptionStack-based buffer overflow in the xl command line utility in Xen 4.1.x through 4.5.x allows local guest administrators to gain privileges via a long configuration argument.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3414-1
NVD severitymedium (attack range: local)
Debian Bugs795721

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)wheezy4.1.4-3+deb7u9vulnerable
wheezy (security)4.1.6.lts1-8vulnerable
jessie4.4.1-9+deb8u9fixed
jessie (security)4.4.1-9+deb8u10fixed
buster, sid, stretch4.8.1-1+deb9u1fixed
stretch (security)4.8.1-1+deb9u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensource(unstable)4.6.0-1low795721
xensourcejessie4.4.1-9+deb8u3mediumDSA-3414-1
xensourcesqueeze(not affected)

Notes

[wheezy] - xen <no-dsa> (Minor issue, xl not used in wheezy)
[squeeze] - xen <not-affected> (xl not shipped in Squeeze)
http://xenbits.xen.org/xsa/advisory-137.html

Search for package or bug name: Reporting problems