CVE-2015-3284

NameCVE-2015-3284
Descriptionpioctls in OpenAFS 1.6.x before 1.6.13 allows local users to read kernel memory via crafted commands.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3320-1
NVD severitylow (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openafs (PTS)wheezy1.6.1-3+deb7u5fixed
wheezy (security)1.6.1-3+deb7u8fixed
jessie1.6.9-2+deb8u5fixed
jessie (security)1.6.9-2+deb8u6fixed
stretch1.6.20-2fixed
stretch (security)1.6.20-2+deb9u1fixed
buster1.8.0~pre4-1fixed
sid1.8.0~pre5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openafssource(unstable)1.6.13-1low
openafssourcejessie1.6.9-2+deb8u3lowDSA-3320-1
openafssourcesqueeze(not affected)
openafssourcewheezy1.6.1-3+deb7u3lowDSA-3320-1

Notes

[squeeze] - openafs <not-affected> (Only 1.6.0 trough 1.6.12)
http://www.openafs.org/pages/security/OPENAFS-SA-2015-003.txt

Search for package or bug name: Reporting problems