CVE-2015-3289

NameCVE-2015-3289
DescriptionOpenStack Glance before 2015.1.1 (kilo) allows remote authenticated users to cause a denial of service (disk consumption) by repeatedly using the import task flow API to create images and then deleting them.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs793896

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
glance (PTS)wheezy2012.1.1-5fixed
jessie2014.1.3-12+deb8u1fixed
stretch2:13.0.0-4fixed
buster, sid2:15.0.0-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
glancesource(unstable)2015.1.0-4medium793896
glancesourcejessie(not affected)
glancesourcewheezy(not affected)

Notes

[jessie] - glance <not-affected> (Vulnerable code introduced later)
[wheezy] - glance <not-affected> (Vulnerable code introduced later)

Search for package or bug name: Reporting problems