CVE-2015-3294

NameCVE-2015-3294
DescriptionThe tcp_request function in Dnsmasq before 2.73rc4 does not properly handle the return value of the setup_reply function, which allows remote attackers to read process memory and cause a denial of service (out-of-bounds read and crash) via a malformed DNS request.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-225-1, DSA-3251-1
NVD severitymedium (attack range: remote)
Debian Bugs783459

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dnsmasq (PTS)wheezy2.62-3+deb7u3fixed
wheezy (security)2.62-3+deb7u4fixed
jessie2.72-3+deb8u1fixed
jessie (security)2.72-3+deb8u2fixed
stretch2.76-5fixed
stretch (security)2.76-5+deb9u1fixed
buster, sid2.78-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dnsmasqsource(unstable)2.72-3.1medium783459
dnsmasqsourcejessie2.72-3+deb8u1mediumDSA-3251-1
dnsmasqsourcesqueeze2.55-2+deb6u1mediumDLA-225-1
dnsmasqsourcewheezy2.62-3+deb7u2mediumDSA-3251-1

Notes

http://lists.thekelleys.org.uk/pipermail/dnsmasq-discuss/2015q2/009382.html
http://thekelleys.org.uk/gitweb/?p=dnsmasq.git;a=commit;h=ad4a8ff7d9097008d7623df8543df435bfddeac8

Search for package or bug name: Reporting problems