CVE-2015-3329

NameCVE-2015-3329
DescriptionMultiple stack-based buffer overflows in the phar_set_inode function in phar_internal.h in PHP before 5.4.40, 5.5.x before 5.5.24, and 5.6.x before 5.6.8 allow remote attackers to execute arbitrary code via a crafted length value in a (1) tar, (2) phar, or (3) ZIP archive.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-212-1, DSA-3280-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)wheezy5.4.45-0+deb7u2fixed
wheezy (security)5.4.45-0+deb7u11fixed
jessie (security), jessie5.6.30+dfsg-0+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)5.6.9+dfsg-1high
php5sourcejessie5.6.9+dfsg-0+deb8u1highDSA-3280-1
php5sourcesqueeze5.3.3.1-7+squeeze26highDLA-212-1
php5sourcewheezy5.4.41-0+deb7u1highDSA-3280-1

Notes

http://git.php.net/?p=php-src.git;a=commit;h=f59b67ae50064560d7bfcdb0d6a8ab284179053c
https://bugs.php.net/bug.php?id=69441
http://www.openwall.com/lists/oss-security/2015/04/16/22
Fixed in 5.6.8 and 5.4.40

Search for package or bug name: Reporting problems