CVE-2015-3330

NameCVE-2015-3330
DescriptionThe php_handler function in sapi/apache2handler/sapi_apache2.c in PHP before 5.4.40, 5.5.x before 5.5.24, and 5.6.x before 5.6.8, when the Apache HTTP Server 2.4.x is used, allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via pipelined HTTP requests that result in a "deconfigured interpreter."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-212-1, DSA-3198-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)wheezy5.4.45-0+deb7u2fixed
wheezy (security)5.4.45-0+deb7u11fixed
jessie (security), jessie5.6.30+dfsg-0+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)5.6.7+dfsg-1medium
php5sourcesqueeze5.3.3.1-7+squeeze26mediumDLA-212-1
php5sourcewheezy5.4.39-0+deb7u1mediumDSA-3198-1

Notes

https://bugs.php.net/bug.php?id=69218
https://bugs.php.net/bug.php?id=68486
Fixed by: http://git.php.net/?p=php-src.git;a=commit;h=809610f5ea38a83b284e1125d1fff129bdd615e7
http://www.openwall.com/lists/oss-security/2015/04/17/3
For details on scope of the CVE assignment: http://www.openwall.com/lists/oss-security/2015/04/17/7

Search for package or bug name: Reporting problems